School Buddy is currently available on any device running iOS or iPadOS!

For the app to properly work on your devices, make sure you meet the following operating system requirements:

iOS Minimum Version: 13.5.0

Did this answer your question?